
The fi rst step is to bring the two exposures into a single layered fi le. 

For this example, we’re adding the darker exposure to the lighter 

image so that it will be the top layer. Select the Move tool (V), hold 

down the Shift key, and drag-and-drop the darker image onto the 

lighter one. Hold down the Shift key until the image appears in the 

lighter fi le as a new layer. This ensures that the two pictures are 

perfectly aligned.

Choose the Brush tool (B) from the Toolbox and set the Foreground 

color to black. In the Options Bar, set the Opacity to 50% and choose 

a soft-edged brush that’s large enough to cover the bottom part 

of the image (ours is 300 pixels). Check the Layers panel to make 

sure the layer mask is active (look for the highlight border around 

the thumbnail). Paint over the image where you want to reveal the 

lighter tones from the bottom layer (paint multiple strokes to reveal 

more of the lighter layer). Reduce the brush size to work on the 

areas where the two images meet at the edge of the rocks. 

Now we’ll add a layer mask to show only the “good” areas of the top 

layer. Depending on the nature of the images you’re combining and 

the complexity of the edge, this is the part of the process that will 

be different for each image. Some scenes may require intricate and 

precise masks, while for others a soft-edged mask will do; we’ll use 

a soft-edged mask for this image. With the top layer active, click the 

Add Layer Mask icon at the bottom of the Layers panel.

We lowered the Opacity to 20% and painted with black over the 

distant hill to show more detail there. To reverse the mask edits, 

press X to switch the Foreground and Background colors, and paint 

with white to bring back the darker layer. To add a contrast punch 

to the top layer, Option-click (PC: Alt-click) on the Create New 

Adjust ment Layer icon in the Layers panel and choose Curves. 

Turn on the Use Previous Layer to Create Clipping Mask checkbox 

and click OK. Adjust the curve as shown. The clipping mask means 

that it affects only the underlying layer.

The composite blend of two exposures

The layer mask
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One classic technique that digital cameras make very easy is blending more than one exposure together for 
contrast control, increased dynamic range, or creative purposes. A variation on this technique is to apply different 
RAW-conversion settings to a single RAW file and then combine the files into a single image. Let’s explore both 
approaches and look at the proper camera technique behind the scenes. 

Before you start in Photoshop, you have to create the fi les so that 

each has a good exposure for a specifi c part of the image. For the 

fi les to align properly, it’s best to be on a tripod. Although handheld, 

rapid-fi re, auto-exposure bracketing may work in some cases, I prefer 

the tripod approach. The tripod is defi nitely a must for long expo-

sures, such as the photos in this example, which had shutter speeds 

of 13 and 25 seconds. I used a 5-stop, solid, neutral-density fi lter to 

force a long exposure time that would totally blur the surf. 

In the images of Makapuu Point on the island of Oahu in Hawaii, the 

sky and most of the ocean looks better in the 13-second exposure, 

while the longer one reveals better detail in the dark foreground 

rocks. I also like the way the incoming surf is blurred into a fi ne mist 

in the 25-second shot. To minimize any chance of vibration that might 

yield a soft shot, I turned off lens stabilization and used an electronic 

cable release. For the purposes of this tutorial, the fi les are JPEGs, 

but I recommend you shoot RAW for the most control and quality.

[ If you’d like to download the images used in this tutorial to practice these techniques, visit www.layersmagazine.com and navigate to the Magazine section. All fi les are for personal use only.]

13 seconds @ ƒ/16, 100 ISO

25 seconds @ ƒ/16, 100 ISO
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The layer mask

Seán Duggan is co-author of The Creative Digital Darkroom and Photoshop Artistry. He teaches regular workshops on Photoshop and Lightroom for photographers. Sign up for his 
free digital darkroom newsletter at his website, www.seanduggan.com.

If you have a single exposure, and it’s a RAW exposure, then you 

can create essentially the same effect as in the previous steps. 

This is useful for scenes that contain moving subjects or where a 

tripod is impractical or simply not an option. The main thing you 

need to do in terms of exposure is bias the histogram as far to the 

right as possible without clipping the highlights (i.e., forcing the 

brightest areas to a total white). This ensures you have the best 

exposure possible for the shadows, which will help minimize noise 

in those areas.

Process the fi rst version of the image in Adobe Camera Raw for a 

specifi c area (in our example, we’re keeping the sky from getting 

too washed out). To preserve maximum fl exibility, click on the blue 

Workfl ow Options link below the preview and turn on the Open 

in Photoshop as Smart Objects checkbox. Click OK then Open 

Object to bring the fi le into Photoshop. Choose Layer>Smart 

Objects>New Smart Object via Copy to create a duplicate smart 

object of the embedded RAW fi le (the smart object duplication 

must be done this way to apply different RAW develop settings). 

Double-click on the thumbnail for the duplicate smart object layer 

to access the Camera Raw dialog and adjust as needed for specifi c 

areas. We used the Exposure, Fill Light, and Brightness sliders to 

show more detail on the rental surfboards. Click OK to apply these 

new settings. Now it’s just a masking job to combine the two. We 

used the Quick Selection tool (W) to make a basic selection of the 

bright sky, then used that to make a layer mask for the top Smart 

Object layer. We then fi ne-tuned the edges using a Brush tool at 

varying opacities.   

If you click on the Background layer’s Eye icon, you can see how the 

layer mask controls which parts of the top darker layer are visible in 

the fi nal composite. Click again to turn on the Background layer’s 

visibility, then Shift-click the layer mask to temporarily disable it and 

view the darker image without the lighter foreground. Shift-click 

the layer mask again to turn it on. The soft-edged layer mask we 

used here works well because the long exposure times blurred the 

water and we don’t have to be concerned with lining up the waves. 

All images by Seán Duggan unless otherwise noted.
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For each fi nished layout, you’ll need to prepare graphics that will 

replace the placeholders. In this example, we saved a photo of each 

city using a simple, logical name (London.jpg, SF.jpg, etc.). We also 

prepared a series of graphics for the star rating of the hotel, again 

using logical names (3stars.jpg, 4stars.jpg, etc.). As you prepare all 

the graphic elements, make note of the fi lenames, and put all the 

graphics in one folder. 

Graphic variables are defi ned the same way, but with some addi-

tional choices. For example, after clicking the Pixel Replacement 

box, we chose Fit as the Method and center for the Alignment—

that way, we’ll still see each city photo in its entirety even if it’s the 

wrong size for the bounding box. For the stars graphic, we chose 

As Is and aligned left since we don’t want the graphic to scale and 

we want them all to appear with the fi rst star in the same position.

From the Image menu, choose Variables>Defi ne. In the resulting 

dialog, a list of all your layers will appear in the Layer pop-up 

menu. Choose a text layer, check the Text Replacement box, and 

assign a name for that variable. When you choose text layers, it 

simply asks you to name the variable for the text replacement. For 

example, for the layer that has the name of the city, we named 

the variable “cityname.” As you assign variables, an asterisk will 

appear beside the layer name. 

In a text editor, enter the name of each variable separated by 

commas. Click Enter. Then, for each separate design (in this case, 

for each city) enter the matching information: the city name, 

the name of the JPEG, the price, which graphic to use as a star 

rating, and so on. Again, follow each entry with a comma. We 

also included a short description of the travel package, being 

careful not to include commas since that would throw things off. 

Use a return to separate each design and save as a text fi le. If 

all your data is already in a spreadsheet, you could export it as a 

comma-delimited fi le and avoid lots of text entry. 
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[If you’d like to download the layered Photoshop fi le, star graphics, and text fi le shown in this tutorial to practice this technique, visit www.layersmagazine.com and navigate to the 
Magazine section. All fi les are for personal use only.]

Years ago, someone introduced me to Mail Merge in Microsoft Word—what a great timesaver, avoiding entering 
lots of names and addresses by hand. Thanks to Variables, Adobe Photoshop can take things one step further, 
replacing text and graphic elements to automatically generate finished layouts.

Create a layered document with the following placeholders: text 

layers in the font and size you want for the text elements, and 

shapes to represent the photographic pieces. You can also use 

actual photographs as placeholders—it doesn’t matter. Tip: When 

deciding on font sizes, use the longest text from all your data; if 

that one fi ts, then you know the rest will as well. 
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Mac OS X for Photographers
Optimized Image Workflow for the  
Mac User

By Rod Wynne-Powell
Price: $39.95
An insider’s guide to optimizing 
Macs for Photoshop and the 
photography workflow.
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Apple Aperture 2
A Workflow Guide for Digital 
Photographers 

By Ken McMahon and Nik Rawlinson 
Price: $39.95
Looks at this powerful application 
in the context of the overall digital 
photography workflow.
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Digital Photo Management
Using Metadata to Store, Protect and Find 
Your Images

By David Riecks
Price: $34.95
A step-by-step guide to setting up 
and managing a system to handle 
analog and digital image files. 

IS
B

N
: 9

78
02

40
81

03
17

Flash + After Effects 

By Chris Jackson
Price: $44.95 
Push Flash to the next level in 
design with After Effects’ robust 
toolset to add supercharged 
visual effects and development 
efficiencies.
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How to Cheat in Adobe Flash CS3

By Chris Georgenes
Price: $39.95
Learn a ton of tips and tricks based 
on real-life working methods to 
help you work faster and more 
efficiently with Flash.

Focal Press Books are available wherever �ne books are sold and through your preferred online 
retailer. Be a part of the Focal Monthly Photography Contest and check out free video and 
audio tutorials at focalpress.com.  And look for us on Facebook, MySpace, and YouTube!
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Once you’ve made sure the data sets appear properly, go to File> 

Export>Data Sets as Files. In the dialog, choose a destination 

folder and a naming system. Click OK to create a new fi le for each 

set of data. 

Since this operation creates a layered document for each data 

set, it’s simple to make any minor adjustments, such as moving 

a layer. Just open the PSD from the destination folder and make 

any changes. 

Back in Photoshop, go to Image>Variables>Data Sets. Click the 

Import button, choose the text fi le you saved, click Load, then 

click OK. With the Preview box checked, you can use the left- and 

right-facing triangle buttons beside the Data Set fi eld to look at 

each set of information to make sure it worked. This is just for 

previewing. When you click OK, your fi le will return to the original 

placeholder document. 

Dave Cross is Senior Developer, Education and Curriculum, for the National Association of Photoshop Professionals. He is the author of Photoshop Finishing Touches and The Photoshop 
CS2 Help Desk Book, and is featured on a series of Photoshop training DVDs.

Assuming that you want fl attened versions of the fi nished graph-

ics, select all the graphics in Bridge and use the Image Processor 

(Tools>Photoshop>Image Processor) to make JPEG versions of 

your graphics. Of course, this operation is designed more for 

50 or 500 graphics instead of just fi ve or six. With a little bit of 

upfront effort, you can save a ton of time thanks to Variables.  
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